Como evitar que apareça o erro #N/D na função PROCV

O erro #N/D surge na função PROCV quando o referido valor não foi encontrado na base de dados que você definiu. Para evitar que ele apareça podemos utilizar a função ÉERROS, veja como:

=SE(ÉERROS(PROCV(A1;B1:C8;2;0));””;(PROCV(A1;B1:C8;2;0)))

Ou seja, Se a função PROCV trouxer como valor algum erro, apareça “nada”, se não utilize a função PROCV.

Um abraço, até a próxima!

Odair Lima

About these ads

26 Responses to Como evitar que apareça o erro #N/D na função PROCV

  1. Odair,

    Sempre recebo via e-mail suas dicas do Jornal do Excel e também repasso para amigos, meus PARABÉNS pela divulgação.

  2. tercio disse:

    USE O SEERRO:
    =SEERRO(PROCV(A1;B1:C8;2;0);””)
    É MAIS PRÁTICO.

  3. Pingback: Como evitar o erro #N/D na função PROCV – Parte II « Odair Lima

  4. fabiano disse:

    Parabéns, a formula deu certo obrigado!!!

  5. jose Silva disse:

    muito obrigado!! valeu mesmo..

  6. dacarpe disse:

    Na minha planilha está aparecendo o erro #N/D mas ele não deveria aparecer, pois há um valor a ser demonstrado. Não estou entendendo o que está acontecendo…

  7. Anielle disse:

    funciona para buscar valor em uma tabela dinâmica?

  8. cyprianogarcia disse:

    Oi, estou usando o PROCV, mas sem a sua dica do éerros e mesmo assim estou com dificuldades rsss
    http://i.imgur.com/E9k1Fy4.png
    O PROCV está puxando os dados da linha errada na outra planilha…o que pode estar ocorrendo?

    Coloquei para procurar o nome por lista, com validação de dados, esse nome é escolhido e inserido (por =C1) na célula D4 – a qual que faz referência na PROCV… mas ele está misturando os dados das linhas…

    Pode me ajudar?

    • Odair Lima disse:

      Olá amigo(a). Peço desculpas mas não entendi sua pergunta. De qualquer forma veja se na coluna onde o excel procura a referência tem algum dado repetido, pode ser isso. Se não for, mande a figura com a função criada para eu dar uma olhada. Im abraço.

  9. Maria disse:

    Muito legal!! deixou minha tabela com aparecia de profissional!!!

  10. Jefferson disse:

    cyprianogarcia tem duas alternativas , vc pode esta escolhendo a coluna errada de busca.. ex
    =PROCV(C1;D4:E200;1;0) o numero 1 representa a coluna D se vc colocasse 2 representaria a E e assim crescentemente. OU experimente apensas travar a coluna de busca ex =PROCV(C1;$D$4:$E$200;1;0).só selecionar o intervalo dentro da formula mesmo e apertar F4…

    quando vc copia a formula e cola na celula abaixo ele automaticamente busca a partir da linha que vc colou, por isso sempre trave seu intervalo de busca.

  11. LEONARDO disse:

    SENSACIONAL!!!
    MUITO FÁCIL.
    OBRIGADO PELA DICA.

  12. paulo disse:

    Deu muito jeito, Obrigado. Paulo Viseu Portugal

  13. Andé disse:

    Solucionei meu problema com a sua solução. Valeu.

  14. ANDRE disse:

    Quando o procv encontra uma célula vazia ele retorna com um “0″.
    Dá para evitar isso também?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.

Junte-se a 57 outros seguidores

%d blogueiros gostam disto: